UFO Extender MP3


  • Please log in to reply
5 replies to this topic

#1 Scamso

Scamso

    Squaddie

  • Members
  • Pip
  • 1 posts

Posted 26 April 2011 - 01:02 PM

Hi, first of all: UFO Extender is great.

My only problem is the music. When I enable the mp3 mod the game crashes after selecting language (so in the main menu).

When I activate the mp3 mod without having any mp3s in my mp3 folder, everything works fine, other than I obviously don't have any music. If I put mp3s into the folder, as soon as said file should play, the game crashes, just like before.
E.g. when I put the Final Briefing mp3 into the mp3 folder (and having *Final Briefing*.mp3 as start menu mp3) the game crashes. If I remove Final Briefing and only add one of the Battlescape mp3s, the game crashes as soon as I enter Battlescape.

Error code is "UFO Defense crashed at 0x76E6B727 with error 0xE06D7363".

I've tried a lot of combinations already, and otherwise the game's working just fine with all the bugfixes and mods. The mp3s I use are alright as well.

I run the XP version on Windows 7 (64bit). I wonder if that's got anything to do with the dlls? Maybe I have to place them somewhere else than the main directory or something? I assume it's got something to do with soundcard (driver) incompatibility with the calls in the exe, though. Weird thing is, SFX works perfectly, just the music crashes the game.

If anyone would know something about this, I'd really appreciate your help.

#2 Vaiper

Vaiper

    Squaddie

  • Members
  • Pip
  • 3 posts

Posted 24 August 2011 - 02:31 PM

Hello

My friend was having excatly same problem. Altought on this site is mentioned what Microsoft Visual C++ 2008 Redistributable Package is required, he claim what it is installed already. Further investigation showed, what if soundtrack format is changed from mp3 to ogg, everythink is playing good and without crashes. So the solution would be convert stuff to ogg.
You can convert yourself all mp3 to ogg and edit accordingly ini file, or download already prepared stuff with appropriated edited UFOExtender.ini

Download link ; Mirror

Install by simply extracting contents to root ufo defense folder and overwriting UFOExtender.ini file when asked

#3 Tycho

Tycho

    Lieutenant

  • Project Staff
  • PipPipPipPip
  • 703 posts
  • Gender:Male

Posted 13 October 2012 - 02:16 AM

The game will crash when trying to play any alternate music files since Seb is using the generic MCI Control to play the music.  It's easy to implement but has problems when another installation changes the codec that windows is using to play the file in question.  This can result in the game crashing or a failure to play music.  The only solution, at this time, is to uninstall any alternate codec packs or players until you isolate the one that is the source of the problem, unless you are familiar enough with codec implementation to work around the problem yourself.

update: There is a link on the TFTDextender UFOpaedia page to an article that talks about how to debug the MP3 problem. Follow the link in my sig to the UFOpaedia page.

Edited by Tycho, 27 December 2012 - 08:23 AM.


#4 Tycho

Tycho

    Lieutenant

  • Project Staff
  • PipPipPipPip
  • 703 posts
  • Gender:Male

Posted 22 June 2013 - 03:22 PM

Starting with version 1.30, MP3s are played through BASE sound library with should elimiated all the codec related problems.

#5 scf500

scf500

    Squaddie

  • Members
  • Pip
  • 8 posts

Posted 10 October 2013 - 11:03 PM

Having problem with v1.31.4 that first geoscape MP3 is played all over again and the other geoscape sounds are ignored. When i switch to v1.29 the problem dissapear.
Any ideas?

#6 Tycho

Tycho

    Lieutenant

  • Project Staff
  • PipPipPipPip
  • 703 posts
  • Gender:Male

Posted 11 October 2013 - 11:22 AM

View Postscf500, on 10 October 2013 - 11:03 PM, said:

Having problem with v1.31.4 that first geoscape MP3 is played all over again and the other geoscape sounds are ignored. When i switch to v1.29 the problem dissapear.
Any ideas?

Just to be clear, the problem is only with the MP3 playback?  Could you post your [music] section for your INI?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users