XCOM Post Mission Crash


  • Please log in to reply
10 replies to this topic

#1 Haet

new
Haet

    Squaddie

  • Members
  • Pip
  • 4 posts

Posted 18 February 2011 - 06:19 PM

I'm using a steam copy of EU with xcomutil and seb's extender. I reworked the weapons in obdata.dat, and the alien weapon loadouts in tactical.exe.

At some point in the game I will finish a mission and when I click "ok" in the score screen the game crashes with this error message:

Xcom crashed at 0x10004E1D with error 0xC0000005 trying to access 0x00245020


I have no idea how to interpret this, or what part of my concoction to blame.

Any words would be appreciated

#2 NKF

new
NKF

    Thinker of Mishandled Edges

  • Site Staff
  • PipPipPipPipPip
  • 3,949 posts
  • Gender:Male
  • Location:In my mind

Posted 18 February 2011 - 08:49 PM

Considering this game is bug central (in both senses of that phrase), it could be any number of reasons and might not be connected with your edits.

Does this happen all the time or just on odd occasions?

- NKF
NKF, wordmakeupper extraordinaire.

#3 Haet

new
Haet

    Squaddie

  • Members
  • Pip
  • 4 posts

Posted 18 February 2011 - 10:04 PM

Whenever it's triggered, it will happen every time I finish a certain UFO mission, making it impossible to continue short of skipping it.

It never happened when I was only using xcomutil.

I'm just hoping to skip the arduous task of randomly turning stuff off and redoing missions.

#4 Bomb Bloke

new
Bomb Bloke

    The Smily Admin

  • Admin
  • PipPipPipPipPip
  • 4,526 posts
  • Gender:Male
  • Location:Tasmania (AU)

Posted 19 February 2011 - 06:58 AM

If it's specifically turning up after the score screen then I'm thinking it's the Interceptor bug mayhaps?
BB's X-Com Projects Page - X-Com Games At GamersGate
You're just jealous 'cause the voices only talk to me :P
We love Tammy! :)

#5 Haet

new
Haet

    Squaddie

  • Members
  • Pip
  • 4 posts

Posted 19 February 2011 - 08:20 AM

I'm not sure exactly what the bug encompasses, but I never save games with interception windows open, or stuff airborne. My savegames already have the value/offset stated.

It happens the moment you click to exit the greentext score screen. At first I thought the problem lied in switching between the .exe's, but it does the first step fine. Now I'm thinking something like xcomutil's research help or ufoextender's no funkers.

#6 NKF

new
NKF

    Thinker of Mishandled Edges

  • Site Staff
  • PipPipPipPipPip
  • 3,949 posts
  • Gender:Male
  • Location:In my mind

Posted 19 February 2011 - 08:30 AM

If this is occuring in a current save, can you start a new game and play a mission and see if that produces the same results?

- NKF
NKF, wordmakeupper extraordinaire.

#7 Haet

new
Haet

    Squaddie

  • Members
  • Pip
  • 4 posts

Posted 19 February 2011 - 09:55 AM

I have. Multiple times. I've even reinstalled everything for an even fresher start.

Sometimes I reach UFO 12, and sometimes not even UFO 3 before it happens. If memory serves it has only happened on ground assault missions, but it has triggered on different ships.

The error message is always the same.

#8 Bomb Bloke

new
Bomb Bloke

    The Smily Admin

  • Admin
  • PipPipPipPipPip
  • 4,526 posts
  • Gender:Male
  • Location:Tasmania (AU)

Posted 19 February 2011 - 10:15 AM

Welp, I can tell you that nothing you do to obdata.dat will affect what happens outside of tactical missions (except maybe what the UFOpaedia shows you). Your alien loadout tweaks might be related if a mistake was made implementing them, though it's unlikely.

XCU may be to blame, but I'm somehow doubting it. The Extender is, in my view, the most likely culprit, as it does its work at run-time; but... well, it's quite possible none of your mods have anything to do with it. I'd advise trying to load the save games in, say, DOSBox without XCU/Extender active, see if they still crash on you.
BB's X-Com Projects Page - X-Com Games At GamersGate
You're just jealous 'cause the voices only talk to me :P
We love Tammy! :)

#9 Lapis

new
Lapis

    Squaddie

  • Members
  • Pip
  • 1 posts

Posted 09 August 2011 - 10:57 AM

Hey ya Haet,

I had exactly the same problem, and I figured out what was crashing my version which is also the steam version using both mods as well. I registered to this site just to tell you haha

My problem was that I had the "No Funkers" mod turned on. The mod makes it so that only people who go on the mission get promoted. After I turned this off it didn't crash for me anymore, I had the exact same crash message as you did as well.

I hope this that fixes your problem

#10 ziarn

new
ziarn

    Squaddie

  • Members
  • Pip
  • 1 posts

Posted 21 May 2012 - 11:02 AM

Gotta say the previous post helped me. Had been tweaking with UFO quite a lot to get it working on my Windows 7 laptop, and everything was working perfectly except for crashing after some successful missions. Turning off No Funkers removed the problem :)

#11 Tycho

new
Tycho

    Lieutenant

  • Project Staff
  • PipPipPipPip
  • 587 posts
  • Gender:Male
  • Location:Nagoya, Japan

Posted 21 May 2012 - 12:10 PM

I believe this was fixed in an August 2009 update to the loader:

(-Fix "no funkers" crash when using split binaries)
"Where's the kaboom? There was supposed to be an Earth-shattering kaboom!" --- Marvin "the great brain" Martian.

UFO Extender home page TFTD Extender home page My UFOpaedia Home page




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users