x-com under dosbox


  • Please log in to reply
6 replies to this topic

#1 crispy

crispy

    Breakfast Cereal Champion

  • Members
  • Pip
  • 41 posts

Posted 04 November 2007 - 11:47 AM

Hi all, I've used x-com CE for a long time on a windows machine ... but I recently switched to a Mac.  I'm now trying to get the dos version working, but I can't seem to get the dos X-com going under dosbox.

could anybody give me a step by step run through for getting x-com working in dosbox?

Dosbox starts with a Z prompt.

I do
mount c /xcom (to mount the xcom file as 'c').

I go to c
do DIR

there are several files to choose from:
cdsetup.bat
full.bat
go.com
install.bat
intr.o
noway.com
setup.exe
small.bat
sound.cfg
ufoc.d
ufocd.bat
welcom.com

I've tried the ones marked in red but so far nothing is working.

Any help would be appreciated.

#2 Bomb Bloke

Bomb Bloke

    The Smily Admin

  • Admin
  • PipPipPipPipPip
  • 4,625 posts
  • Gender:Male
  • Location:Tasmania (AU)

Posted 04 November 2007 - 01:13 PM

If memory serves, you start off by running "cdsetup" with the game path as a parameter (in your case, the full command should be "cdsetup c:").

The setup program should then run, allowing you to configure the sound info. Under DosBox you'll be going for a SoundBlaster, I use the SB16 for choice (default values for everything else).

Once that's done you should be able to boot the game with either the "ufo" or "ufocd" batch files (the former of which is created during the above setup process).

If this isn't working for you, give some more info on what "not working" means.
BB's X-Com Projects Page - X-Com Games At GamersGate
You're just jealous 'cause the voices only talk to me :P
We love Tammy! :)

#3 crispy

crispy

    Breakfast Cereal Champion

  • Members
  • Pip
  • 41 posts

Posted 04 November 2007 - 02:39 PM

Thanks, bomb bloke.  Did what you recommended.

I'm getting only a black screen.  Note, other dos games have worked for me, so I know dosbox is basically okay.

At the top of Dosbox, it says:
(When I type UFO at the c prompt, I get)
DOSBox 0.72, Cpu Cycles:  3000, Frameskip 0, Program:  DOSBOX

(when I type UFOCD at the c prompt, I get)
DOSBox 0.72, Cpu Cycles:  3000, Frameskip 0, Program:  Intro.

This lasts for about one minute, then the program changes to DOSBox.

I pushed up the cycles and frameskip, but no change.  However, after two minutes of waiting the program still says Intro for UFOCD, but I don't know if it means anything.  I pushed cycles up to 6500 and frameskip to 5, but don't know if it really had any effect.

Could be the program is faulty, or it might simply not like my mac.

#4 Bomb Bloke

Bomb Bloke

    The Smily Admin

  • Admin
  • PipPipPipPipPip
  • 4,625 posts
  • Gender:Male
  • Location:Tasmania (AU)

Posted 05 November 2007 - 02:35 AM

So the setup programs work ok, you only get the black screen issue when you try to play the actual game?

Not really sure what to suggest on this one...

Try running setup again, and disabling all the sound options. If that fixes things, try other configs until you get it running perfectly.

If nerfing the sound doesn't do the job, make a copy of "ufocd.bat" (call it "ufocd2.bat" or something) and open it with notepad (or whatever Mac's have for text editing). Remove all the lines that read "%1ufoexe\black", save the file, and run it.

If that doesn't work, edit the batch again, and nuke the "%1intro                %1" line, and finally "%1sound\sndstart" if all else fails.
BB's X-Com Projects Page - X-Com Games At GamersGate
You're just jealous 'cause the voices only talk to me :P
We love Tammy! :)

#5 crispy

crispy

    Breakfast Cereal Champion

  • Members
  • Pip
  • 41 posts

Posted 05 November 2007 - 02:09 PM

Hey, thanks for the help.

I tried all that and it either A) gives me the black screen, or B) hangs up.  I tried different variations, but not luck.  I'll take a break for now and try again another time.

Thanks for your help, though.  I appreciate your time.  I guess x-com just doesn't like my mac.

#6 crispy

crispy

    Breakfast Cereal Champion

  • Members
  • Pip
  • 41 posts

Posted 16 November 2007 - 01:48 PM

Update:

Okay, just as background here, years ago, my brother bought me the X-Com Collector's Edition as a present.  What a brother!  When I switched to Mac this summer, I could no longer use CE without putting Windows on my Mac.

I decided instead to use the dos version of X-Com on dosbox for Mac.  Problem:  The version I've been trying to play on dosbox started as a zip file.  Apparently, because some of the files are old formats that Mac OS X is not familiar with, when OS X unzipped the file, some of the execs got messed up:

do4gw, intro, run, tactical and geoscape

In other words, all the stuff I needed to run the game.  After much help from some very, extremely patient experts, I finally solved the problem, and the solution was 100 times easier than half the stuff we tried before we found the solution.

Solution:
If Mac does not like your dos version of X-Com:

unzip the zip file on a PC, then transfer it to your mac.  Should work fine.  I only checked it for a second, but I think there's no sound.  No problem for me though.  I'll just put on some tunes!

Update:  wrong.  sound's okay!

#7 Bomb Bloke

Bomb Bloke

    The Smily Admin

  • Admin
  • PipPipPipPipPip
  • 4,625 posts
  • Gender:Male
  • Location:Tasmania (AU)

Posted 16 November 2007 - 08:25 PM

:D
BB's X-Com Projects Page - X-Com Games At GamersGate
You're just jealous 'cause the voices only talk to me :P
We love Tammy! :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users