Need help with MSDE/S3 Editor


  • Please log in to reply
4 replies to this topic

#1 mockingbird

mockingbird

    Squaddie

  • Members
  • Pip
  • 18 posts

Posted 06 May 2007 - 03:38 PM

Greetings and salutations!
This is my first post on StrategyCore.

I'd like to get into modding Silent Storm, yet it seems that fate does not want me to (-:
More specifically I'm having a problem with the Silent Storm editor which won't run.

I browsed through the topics here and on the official forums and I haven't seen anyone having
similar problems so I decided to post a new thread.

I have the Silent Strom installed (Polish version Gold Edition - Silent Strom & Sentinels)
I have downloaded&installed MSDE2000 (the lousy distributor didn't bother including it with the original game :D )

What follows: the editor does not even run, all I get is a cute errorbox:

Source: "Microsoft OLE DB Provider for ODBC Drivers"
Description:"[Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user 'sa'. 
Reason: Not associated with a trusted SQL Server Connection."

While the message is fairly self explanatory, I don't have a clue where and how would I associate the sa login :D
My best bet is Windows XP's Control Panel/Admin Tools/Data Sources (ODBE), but this is where I get lost.

I tried to get through the MDSE manual, but it proved to be more confusing eventually.
I guess databases are not really my cup of tea.

So um, please help, anyone? :)

#2 LCJr

LCJr

    Squaddie

  • Members
  • Pip
  • 12 posts

Posted 06 May 2007 - 05:24 PM

The Editor trys to use the default password for the SQL server install.  Hopefully someone can chime in and tell you how to change the password in the editor because I'd like to know myself.

In the meantime uninstall the SQL server and delete the Microsoft SQL Server folder, if you leave the folder you'll get an error on reinstall.
Before you reinstall the SQL server check the setup.ini and make sure it has the line "SAPWD=simple".  Don't mess with the password when reinstalling and it should work.

#3 mockingbird

mockingbird

    Squaddie

  • Members
  • Pip
  • 18 posts

Posted 06 May 2007 - 06:26 PM

@LCJr
You sure it is the password? I thought it's rather the issue of the login name. 
(and since 'sa' SEEMS to be the default for system administrator, I am a bit clueless
 as to why it is "not associated" etc.)

In my little imaginary world if the password were incorrect it would have asked me for one upon logging in :D

Yeah, I know about the *.ini (without editing it MSDE won't even install) and I followed the forum instructions to make the password "simple." Still won't work :D  
Thx for the info anyway.

#4 Knan

Knan

    Napalm squaddie

  • Members
  • PipPipPipPip
  • 556 posts
  • Gender:Male
  • Location:XCOMOSL

Posted 06 May 2007 - 06:28 PM

Try an older MSDE.

#5 Ros

Ros

    Squaddie

  • Members
  • Pip
  • 48 posts
  • Gender:Male
  • Location:Poland

Posted 07 January 2008 - 02:21 PM

I've found out that the problem lies in loging to SQL server using only "Windows authentication mode", and to run S2 editor you need to change it to "mixed authentication mode". There is one catch, though.
To do it, you need to have SQL Enterprise Manager (part of SQL Enterprise Edition which isn't for free) or SQL Server Management Studio Express (which is for free and worked for me). So I think solution is obvious. :oh:
Download it from HERE, install and run from "Start->All Programs->Microsoft SQL Server 2005->SQL Server Management Studio Express".

Logon as normal and now you should have 2 windows:
1. right - "Summary" of your SQL server,
2. left - "Object Explorer".

In "Object Explorer" window do a right click on name of your SQL server, and choose "Properties". Now go to "security" page, choose "SQL Server and Windows Authentication mode", click "Ok" and voila.

However in Polish version of S2 Gold still there's something wrong... The game couldn't find file "S2AGAME_Data.mdf" in \Res folder (instead I've had file "A5GAME_Data.mdf") and I was getting one error message after another. So either it's a problem with editor (no patch installed ??), my install got corrupted or editor doesn't work with Polish version of the game.

Right know I've uninstalled S2 Gold from one of my computers and I will try installing English  version instead, still fighting with Polish version on another. If I will discover anything I'll let you know.


Ros.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users