RBMOD 6.7 released!


  • Please log in to reply
79 replies to this topic

#21 Kret

Kret

    Lieutenant

  • Site Staff
  • PipPipPipPip
  • 759 posts
  • Gender:Male

Posted 09 April 2004 - 02:35 PM

Aralez, regarding the appearance of those 2 particular rets, I believe it comes from the difficulty setting. Hard setting add 20% more enemies to any mission (this can be modded if anyone wants to). How it does it I don't know, but there's a chance that the game will "clone" aliens to achieve this, including those aliens.

Relevant file:

strategic\configs\listofdifficulty.txt
There's always some dirt to dig out

#22 Aralez

Aralez

    Forum Grandpa'

  • Fan Fiction
  • PipPipPipPipPip
  • 1,670 posts

Posted 09 April 2004 - 03:46 PM

You are right i think. I play on hard, and tested on medium.

I know this file. I even thought about adding a new difficulty-level (something like "superhuman" in XCOM). Don't know if this is possible, but i gonna try.

#23 Aralez

Aralez

    Forum Grandpa'

  • Fan Fiction
  • PipPipPipPipPip
  • 1,670 posts

Posted 09 April 2004 - 04:36 PM

I tried several values from 0.0 up to 20.0 and the number of enemies didn't change much. With 1.2 there were 21 enemies with 20 there were 22. Then i tried 1.8 and had 14 (!?). When i started on easy with 0.0 i had seven enemies. I think the number in listofdifficulty.txt is MAYBE meant for enemy teams.

The number of enemies in a team is most probably determined by the listofenemy.txt !

I gonna try and edit that file (gonna raise numbers of enemies to 10 instead of the usual 4 or 5 and see if it works).

CU later

------------------------------------------

Later:

There seems to be a maximum of enemies and as it looks it's somewhere between 22 and 30. When there are more, the game crashes.  :( So basically the biggest number of enemies you would encounter on a two-part mission lays around 44, this looks pretty much like the numbers from this thread: Thread

This means a plugin with a new difficulty level or more enemies seems not to be possible. One could maybe change the other numbers in the listofdifficulty.txt (enemy damge, own damage research time etc.) but not the numbers of enemies.  :(

#24 Lurker

Lurker

    Lieutenant

  • Members
  • PipPipPipPip
  • 418 posts

Posted 09 April 2004 - 11:02 PM

Thanks for your help everyone.

I downloaded another fresh copy of RB 6.7.

I started yet another game profile without any mod.  Played a game, and then I installed the mod and did ALLITEMS.  Decided to try something different instead of starting the new game profile with the Rebalance already installed.

After doing ALLITEMS and with one mission under my belt, I loaded up with good stuff, and then went to the only standing mission on the board, and when I got there, Frozen Aliens.

It looks like I have really stepped in it now!!

I get one mission without Frozen Aliens, and then that's it.

Now the crusade really begins.  I need to go back to my old saves and Rebalance 6.61 and see if I'm getting Frozen Aliens with that.  If I'm getting them everywhere and everywhen, then it looks like I need to uninstall and reinstall UFO:AM.

I'll have to do the date sort thing that Kret suggests before I uninstall and reinstall.

If my 6.61 plays fine, and 6.7 still creates Frozen Aliens, then there's possibly some hidden incompatibility between 6.7 and the English version of UFO:AM 1.3?  What language version are the rest of you playing 6.7 with?

I need to download Aralez's recent 6.7 saved game and see if that will get me in without frozen aliens.  To test all of this, though, will take some time, because I get the first mission free without frozen aliens.  It's the second mission I have to get to in order to get them

I do quit without saving when I get the Frozen Aliens.  That made them go away and never come back for me also, one time a very long time ago.  Maybe what I need to do is delegate away all the missions before installing the Rebalance 6.7, so that new missions can be created under the auspices of the 6.7 Rebalance?

Like Kret says, this is a most elusive bug or glitch.  But so far, it seems to be on my hard drive to stay.

I'll report back in, whether I find a solution or not.  Meanwhile, keep the ideas coming.  I sincerely thank you.  I will read and re-read your input and give different things a try.

BTW, how do you do a file compare, if I decide to download yet another copy of Rebalance 6.7?  I deleted the original 6.7 download.  I have never seen file compare with Windows XP, but I was sure wishing that I had that feature when I downloaded the second copy of 6.7.

It looks like I'm going back to school.  Maybe I should just uninstall now and reinstall and get it over with, but my UFO:AM CD is getting scratched up, actually it came that way, so maybe the source of the problem is there?

Oh well, before reinstalling, I should probably go back to RB 6.61 first and see if it is now producing Frozen Aliens, don't you think?  I, too, am at a bit of a loss.  It's been a long while since I have had Visible Frozen Friendly Aliens.  The last time I had them was when I had ALPine installed.  I ended up uninstalling and reinstalling then in order to get rid of ALPine.  Maybe I need to download and install ALPine now and see if that will make the Frozen Aliens go away this time around?

Hmm.

#25 Lurker

Lurker

    Lieutenant

  • Members
  • PipPipPipPip
  • 418 posts

Posted 10 April 2004 - 01:22 AM

I decided to keep a log, like the 'notorious' UFOMAN did over on Altar's site.  Hope people here don't mind.  I can't remember everything unless I write it down.  Kinda long.

--

First test.
No Frozen aliens.  No Mods.  Unmodded tactical in the past completed, thus at start of fresh new game profile.  Went to another Tactical.  No Frozen aliens.  Saved. Quit.
Installed 6.7 Rebalance during interim.  Loaded saved Tactical.
No Frozen Aliens, same aliens as before I saved and quit.  Finish this mission with 6.7 lurking in background.
No ALLITEMS.
Next mission, a mission offered before 6.7 mod install.
Frozen Aliens in that tactical, possibly due to mid-tactical 6.7 introduction.
I thought maybe ALLITEMS was giving me frozen aliens, this time I didn't use ALLITEMS, and still got frozen aliens from 6.7.

--

Second Test.
Went back to Unmodded Save.  6.7 Installed.  Loaded Unmodded save with 6.7 installed.
Delegate away the mission created before 6.7 Install.  No missions on Geoscape.  Save.
Quit.
Goal, to delegate away all non-6.7 missions and let 6.7 create the missions from here on out.
New 6.7 tactical mission.  No Frozen Aliens.
Lost everyone to Poppers.
No ALLITEMS used.
Another mission.
No Visible Frozen Aliens!!
Thinking maybe need to let 6.7 create the missions.
Forced end mission or abort since I had 'continued' to get a couple more aliens.
Four "BOOM"s reported in capture list when I abort.
When I get back to base, there are four items in the OTHER inventory with NO ICON or an invisible icon.  I assume they are the captured "BOOM"s or are possibly the results of four unkilled Poppers?  I don't know.  In the past, I thought that the NO ICON items building up in OTHER inventory become %d's in future captures.  But, who knows.
Also ICON SPIT in Heavy Inventory.  So, the NO ICON boom is not the Spit.
Second Mission.  No frozen aliens!!!!
Lost all my soldiers to poppers again.
Three new soldiers on way back to base.
Quit, load.  ***

Four soldiers.  
Do ALLITEMS - Power Armor, Good Stuff, then off to 6.7 created mission.
Bah!!  Frozen aliens everywhere.

*** Go back and load no frozen aliens point.
No ALLITEMS this time around.  UZI's
Go to same mission.
While loading tactical mission, computer ploinks or beeps and freezes, and when I escape it drops to desktop.  Stalkwalk 126 error in popup box.  My first Stalkwalk 126 error from UFO:AM ever!
Shut down 'puter.
Reboot.

*** Load no frozen point again.
Go to same mission.  No stalkwak error second time around, but frozen aliens.  That test is done.  Everything results in frozen aliens or glitches.

Do the invisible icons in the OTHER inventory cause the glitches?  Still think that it's popper leftovers.

--

If you want,  I can zip up a batch of NO ICON no-name boom stuff in Geoscape Inventory and send that to you, Aralez.  I assume it is purple popper leftovers.

--

Getting tired of testing.  Will take some time to dream up some another test.

Probably create a new game with Rebalance 6.7 in there from the start.  See how far I get before frozen aliens.

Now I think about it, I do have 5.62 of the Rebalance on an older Windows ME machine that all was working, last I checked.  Maybe I'll carry 6.7 of the Rebalance down there and try to see if it gives Frozen Aliens on that machine.

If it does, then probably an incompatibility between 6.7 and my CD or my English version of UFO:AM.
If no frozen aliens on other WinME machine, then probably need to uninstall and reinstall UFO:AM on my WinXP machine.  That sounds like a good test.

Need to try Krets sort test.

But, tired of testing and tired of game right now.  Lightning outside, family playing card game on inside.  Time to quit for now.

I sure hope people won't get upset at me for posting this stuff.  I guess if you do, let me know, and I will quit, or go private to Aralez with the log.  I don't need to do this testing and log reporting in public, unless others in public are wanting to see and know about it.  Let me know, either way.

#26 Lurker

Lurker

    Lieutenant

  • Members
  • PipPipPipPip
  • 418 posts

Posted 10 April 2004 - 05:10 AM

THIRD TEST:

I burned all the goodies to CD, and I then took Rebalance 6.7 downstairs to the Children's machine.  It's a Windows ME machine.  That machine had version 5.62 of the Rebalance running on it for a couple of hours while a child played and then got bored with it.

After removing 56_mod.vfs and installing 67_mod.vfs on WinME, I created a new game profile, Europe HARD.  (That WinME 'puter is a pain.  It will no longer allow me to create New folders.  Have to copy a folder, delete the contents, and then rename it, to get a New Folder.  I wonder if that's a present from the new Nero 6 that we put on that machine.  So many variables!)

I then pressed PLAY and let 67_mod create a new game.  Skipped the Tutorial.  I got Conventional Armor, smoke, TNT, knife in Equipment section.  Working 6.7, cause of the TNT!  Got my third soldier.  No ALLITEMS.   Loaded up soldiers and went to the first available mission.

Frozen Visible Aliens immediately.

Except for the burning of the CD, that was a very quick test.

This time I just ran it and let it automatically END as it does with frozen aliens, and I went to a second mission with frozen aliens, and let it run and automatically END as well.  I could do the whole game that way winning all the missions from beginning to end automatically I suppose.  Dead end!

So, 6.7 of the Rebalance Mod is producing Visible Frozen Aliens on two different machines of mine, my WinXP machine and my children's WinME machine.  Maybe, I should see if I can try installing the game on one-of-my-friend's Win98 machine, but I don't think it will make any difference.  (And, don't know if he would want that on his machine, if it's showing signs of bugs.  Some people get nervous or superstitous.  Don't know if it's worth the effort or time.)

Anyway, with my English UFO:AM CD and my installations from that CD, I'm beginning to imagine that I'll get frozen aliens on any machine onto which I might install Rebalance 6.7.  I'd have to buy another UFO:AM CD, in order to get a truly different sampling.

Thinking about other common denominators I should mention.  There was all sorts of hype about the new Nvidia Drivers awhile back, and I did drive clean and install new video drivers on both machines, the same driver.  It was the generic Nvidia 5664 drivers that I downloaded awhile back.  Maybe I can try going back to the older drivers or the drivers made for the specific card and see if that makes any kind of difference.  But, there are completely different Geforce cards in each machine, so I don't see why 6.7 should consistently do Frozen Aliens on completely different video cards.  Don't know if that's an important avenue to pursue.

So for now, I think will try going back to Rebalance 6.61 on both machines, create new profiles, and import Aralez's 115.zip save game and see if I get frozen aliens with Version 6.61 of the Rebalance on either machine.  I wasn't getting frozen aliens with any Rebalance on this WinXP machine until RB6.7 came along, but I don't know what 6.61 will do on the children's machine.  And, I don't know yet if the new change of events has now permanently polluted both my machines where UFO:AM is concerned.  So, gotta try going back to 6.61.

If it's some incompatibility between my personal 'scratched' CD and RB6.7, then I will never find a solution.

Meanwhile, if anyone can find people with the English version of UFO:AM and 1.3 update, and have them create a new game profile and try Rebalance 6.7 on their machines with ALLITEM's or with Aralez's 115.zip, that would be helpful to me, so that I can know if it's my CD that's causing the problem or if everyone with a specific language version is having the problem.  Anyway, that's a plea to all the other (non-Aralez and non-Kret) English brand UFO:AM players out there.

I do feel a compulsion to try to get 6.7 on yet another different Win98 operating system and machine and Nvidia driver, but I'll have to see how that compulsion goes.  Meanwhile, I'll go back to Rebalance 6.61 on my WinXP and my children's WinME, and see how that goes.

#27 BlackAlmaz

BlackAlmaz

    THE GHOST FROM XMAS PAST

  • Members
  • PipPipPipPip
  • 706 posts
  • Location:Sydney/Australia

Posted 10 April 2004 - 05:38 AM

has any met the bfg...on ther 2nd mission i have and i lost all my best equipment and guys.....so....its unbalanced.......it loocked like the scorpion..so i thought he was an easy kill....(talk about holding back)

trans use nades.....thats a bit of trouble.....not to much...

but the bfg and all the high tech weapons apear to early when trens have them....
played on easy...and mediem same problem..

one last faver i ask for..is giving me a sniper form the very start.....or early in bases......extrme range...but as power full as a a rifle...(fal)...or the other way around....

no make it like the lurker but no as strong
"THERE AT THE BERACADES!!!....THERE IN THE PERIMETER!?.....THERE IN THIS ROOM!?" ALIANs

#28 Lurker

Lurker

    Lieutenant

  • Members
  • PipPipPipPip
  • 418 posts

Posted 10 April 2004 - 08:29 AM

TEST FOUR:

I got rid of 5.62 on the Children's machine and installed RB 6.61.  I created a new profile, Europe HARD, and started a new game.  Skipped tutorial.  Did two separate saves, one save named 115.

Quit game.  I then copied Aralez's 115.zip files over in place of mine.

I went back in, loaded up the soldiers, and went to Los Angeles base 33 capture mission.  No problems.

I saved the game before selecting Next Area.

While loading next area, the game hung with this message on the WinME desktop:

assert_fatal
ver: UFO:AM RELEASE 1.3 file
C:\ufo_src\UFO\UFO\weapon.cpp
line: 449 item Template


SO,
I shut down WinME, rebooted, loaded UFO:AM, and loaded my last save, and then once again selected Next Area, and in it goes to next area.  All fine.

Finish the mission, get two bases for it.

I then load up soldiers and head to Alaska for the Third Mission.  Get to Alaska, and surrounded my aliens.  A tough fight, but NO visible frozen aliens.  Didn't finish that mission, just saved it.  Running out of time.

I never got in three separate mission parts with 6.7 without frozen aliens, so I assume the frozen aliens are gone with 6.61?

My daughter likes dressing the soldiers and aliens in the crew, but I can't get her to go on tactical missions, and despite her initial exuberant enthusiasm when she sees Aralez's alien crew, she will only play Barbie dolls with the soldiers for about an hour or so before she gets bored.  I need someone besides me to play tactical in order to speed up the mission.  Maybe I can con my son into it if I can pull him away from schoolwork.  My daughter wanted Aralez's 115.zip crew on her WinME machine, so I imagine she'll be playing with it, but don't know if I can get her to run tactical testing for me to make sure that Frozen Aliens never appear.

Anyway, I think 6.61 works.  The assert_fatal is what I call a transition glitch.  I think I experienced it a couple of times before whenever I was installing and running a saved game from someone else's computer onto the WinME machine.  It's a self-correcting glitch.  I think it's the transition that takes place as his saved game becomes my saved game.

I don't think the WinME machine will give me any more problems unless I switch back to RB 6.7.  But, I don't have time to test it now.  Wanna get WinXP machine working right again.

#29 Kret

Kret

    Lieutenant

  • Site Staff
  • PipPipPipPip
  • 759 posts
  • Gender:Male

Posted 10 April 2004 - 08:37 AM

@Lurker:

There's a command line instruction that is intended for file comparison. It's FC and it's one of the commands inherited from good old DOS. For a binary compare (wich you should do for vfs files) you type:

   FC /b <file1> <file2>

paths are accepted in each <file> ID. If there's no difference, then it will say so, if there is it will start displaying a list (long or short) of offsets where there's a difference.

I recommend that if you really want to test this carefully have a fresh install of UFO:AM followed inmedietly by the 1.3 patching up (this of course includes pre-patching to 1.2) and only have the RBmod installed. I think you already did this, but making sure of it.

Since this bug doesn't seem to appear on every single mission makes it hard to spot. It is even possible that it's not a bug, but an after effect of a previous bug. Since you're getting odd inventory items in your stores, this could be well what's causing the fronzen aliens.

I'm not testing the mod, but am looking into the contents of the mod, let's see with what theory I can come up with.

BTW: you have to con your son into playing a game rather than do homework? Does his "homework" have to do something with "Taking over the world"?
There's always some dirt to dig out

#30 Lurker

Lurker

    Lieutenant

  • Members
  • PipPipPipPip
  • 418 posts

Posted 10 April 2004 - 09:04 AM

The UFO:AM installation on my Children's PC (the WinME machine) is a fresh installation, as far as I know, though it's been fresh and relatively unused since Rebalance 5.62.  Never set up WinME machine to do ALLITEMS.

Not so fresh on my WinXP machine, but never had Frozen aliens at all on WinXP machine until Rebalance 6.7.  And, with RB6.7, I have now had frozen aliens on both machines.

Thx for the FC explanation!  Gonna probably end up downloading RB6.7 a third time before this is over, and would like to check if they compare right.

Only used the RBmods on this WinXP machine.  Never have had any other mods installed here, except the eq_mod long ago.

6.7 Frozen Aliens come in second part of a mission, Next Area, or next mission, though they came immediately on WinME machine after creating a new profile or new game.  Never experienced Frozen Aliens with any previous rebalance, and I've played constantly since February or so.  Only RB 6.7.

--

Son, funny story there.  Years back, he not doing so well in school.  I sat him down and watched Starship Troopers with him.  I said, "Now see what happens to Rikko when he does poorly in school."  He gets to be there face-to-face with the Bugs, in the infantry.  See what happens to smart boy and smart girl who does well in school.  Smart boy becomes Colonel and does testing in safety away from front lines.  Girl gets to navigate star ships.  I says, "If you drafted into the army and you appear dumb, you go straight into infantry and get to take point and be first one in line to be shot or torn apart by BUGS.  If you smart and do good in school, they make you an officer, and you sit back behind the lines in a tent and give the orders.  If you super smart, you get to make the weapons, and then you are the one that the infantry is protecting."

He has put homework first ever since and has been tops in class ever since.  I'm not going to fight it.  He got the message from Starship Troopers, the one I hoped he would get.  He does homework first, and then plays games if any time left over.

--

EDIT:  Actually, it's not really about smarts or intelligence.  My son was always smarter than average, but he was never all that dedicated until he saw Starship Troopers and made his own conclusions what it meant to him.  In Starship Troopers, Riko was a playboy of sorts, and thus landed in the infantry, but his hidden intelligence or smarts started to emerge as he became more dedicated and disciplined.  Dedication, loyalty, and discipline can easily trounce genius, but watch out and see what happens should genius and discipline just happen to combine in the same package, then you end up with something like Aralez's rebalance mods.

#31 Lurker

Lurker

    Lieutenant

  • Members
  • PipPipPipPip
  • 418 posts

Posted 10 April 2004 - 09:14 AM

@Kret:  If I zip up anything for Aralez, like NO ICON other items or some such in terms of saved games.  Want me to try again to send them to you, too?  I didn't get through to you last time, but I would try zipping the VFS files this time around and maybe you'd have enough room?

#32 Kret

Kret

    Lieutenant

  • Site Staff
  • PipPipPipPip
  • 759 posts
  • Gender:Male

Posted 10 April 2004 - 09:29 AM

Here's some early results from my analisis:

Aralez uses equipsets for new aliens that use "inherit" weapons (spitter, popper, etc) but the problem here is that equipsets are designed for carryable weapons, nor really inherit ones, that's probably why you get them listed in your inventories when completing a mission with them in it.

Here's a sample taken from the floater thingy that fires paralysing rays (I actually forgot it's name  :( )

Quote

  CREATURE
    ORIGIN M
    UNIT_TYPE COCOON
    SIZE 2
    WIDTH 200
    HEIGHT 240
    ADD_HEIGHT 100
    CONSPICUITY 2.0
    TRESHOLD 2.0
    CARRIABLE FALSE
    ROOF 0
    ARMOUR TICO0
    EFFECT_HIT "tactical/particles/hit_effect groups/blood_mutant_02.pgrp"
    EFFECT_DEATH "tactical/particles/hit_effect groups/rozprsk_mutant.pgrp"
    SOUND_HIT "share/sound/wavs/mutants/scream2.wav"
    SOUND_DEATH "share/sound/wavs/mutants/scream+growl.wav"
    HEALTH 1500
    FALL 500
    WEAPON1 RG-COCOON
    MELEE_TIME 0.0
    ICON "tactical/models/interface/items/creatures/mb.txt"
    WEIGHT_LIMIT 50.0
    WEIGHT 100.0
  END_OF_CREATURE

Notice where I've marked the line with a weapon. This is actually how you should define inherit weapons, but this means that you need to "create" a new creature type, with it's consequences and all. Aralez doesn't do this, not quite sure why. He uses an unusual system to create the "new" aliens.

More to come...

EDIT: Aralez, notice the 3rd, 4th, 5th and 6th lines? I think these define the "size" of the alien. The 1st one defines the actual space used by the alien in matter of squares (value is squared) The rest seems to "stretch" the model of the alien to that size, and the last might possibly be used for "floating" aliens (how much above ground they "walk") Need further analisis of this.

EIDT 2: Further analisis makes me believe that the 4th value is not used to determine the floating factor, since all creatures have some value or another (yes, even humans and rets)
There's always some dirt to dig out

#33 Lurker

Lurker

    Lieutenant

  • Members
  • PipPipPipPip
  • 418 posts

Posted 10 April 2004 - 09:43 AM

Appreciate your ideas Kret.

--

Okay, my next project:
I downloaded RB6.7 twice with my new updated GetRight 5.1.  I believe that I downloaded the previous RB mods with GetRight 5.02 or with the old fashioned Microsoft way.

I uninstalled GetRight, and now I will download RB6.7 with Microsoft save method, and if I don't get disconnected during download, I can then File Compare two separate downloads and see if the new GetRight 5.1 isn't downloading right.

Here goes.

#34 Kret

Kret

    Lieutenant

  • Site Staff
  • PipPipPipPip
  • 759 posts
  • Gender:Male

Posted 10 April 2004 - 10:18 AM

Hmm... I just tried to play the game with the rbmod 6.7 and my version just crashed to desktop. Will try again...

Tried again and this time the 1st mission loaded ok, but then it crashed when generating the 2nd one. All I can say from this is that 6.7 is not fully stable. The reason why needs a lot of investigating
There's always some dirt to dig out

#35 Lurker

Lurker

    Lieutenant

  • Members
  • PipPipPipPip
  • 418 posts

Posted 10 April 2004 - 11:22 AM

Okay.  Downloaded a third copy of RB6.7 using a different method.  I did binary File Compare between used zip and the new download, and No Differences were reported.  They are the same, so my 6.7 problems can't be blamed on faulty download.

--

Thanks Kret.  I needed someone besides me with an English version (or with another CD) of UFO:AM to verify that 6.7 isn't stable.  From some of his screen shots, I think Aralez is developing and testing Rebalances on a different language version, and thus possibly getting different results?

Something 'alien' was added to 6.7 that wasn't there in 6.61, and 6.7 is the first and only time that I have had real and serious problems with a Rebalance since 4.X.  And I started having my Frozen Alien problem only with 6.7.

Anyway, Aralez and everyone else, don't delete your copy of RB6.61.

I suggest that maybe Aralez could restart with 6.61 and slowly rebuild RB 6.7 one piece or one change at a time in an attempt for us to see if we can isolate the offending item.  Maybe we'll have to leave the offending item out if we can isolate it, or maybe Aralez can use some of your tricks, Kret, in order to modify the offending item so that it no longer glitches once it has been isolated.  Personally, I hope that it isn't the WTD that's the offending item, cause I really love that addition.  There's gotta be a workaround, but the source of the problem has to be isolated first so that development can then focus on the cure.

It was a long time ago, but from what I remember, the last time that I had Frozen Aliens was when I did an install of ALPine.  I had to uninstall ALPine and reinstall UFO:AM in order to make it go away.  I was getting crashes as well with ALPine.  I had installed some ALPin plugin apparently that was 'alien' to my machine.

I only use the RBmod, so that if things go wrong, I can point to the RBMod as the source of the problem.  The Rebalances have been very stable for me, surprisingly and exceptionally so, until 6.7.  So, hopefully, our input will be useful for Aralez, cause RB6.7 was a dream come true for me.  Aralez read my mind when he came up with that wish list.  The couple of times I got to try the WTD, I was a believer and a fan all over again!  Awesome.

#36 Kret

Kret

    Lieutenant

  • Site Staff
  • PipPipPipPip
  • 759 posts
  • Gender:Male

Posted 10 April 2004 - 12:20 PM

Actually, my version is the spanish one, but don't think that matters much since aralez doesn't touch the localization pack where differences could actually appear from pack to pack. As for the rebuild of RB, I would also recommend to Aralez that he uses 2 separate vfs files, one for weapons (and their magazines and such) the other containing the equipment sets and new aliens. This makes it quite easy for debugging purposes appart that it gives the choice to the player that has reached the limit and says "OK, I've had enough of these RB mutants kicking my arse but I don't wanna loose the RB weapons" and can just remove that file while leaving the other.
There's always some dirt to dig out

#37 Aralez

Aralez

    Forum Grandpa'

  • Fan Fiction
  • PipPipPipPipPip
  • 1,670 posts

Posted 10 April 2004 - 05:48 PM

I have a german copy of the game, but as Kret said: The RBMod doesn't use the localizationpack.vfs-file which is used for language, text etc.., so this shouldn't be the source of the problem.

@Kret: I added the aliens the way i did, because the game can recognize it and then display a name over it. The other way (adding them like Fulbys Human Raiders) works, too. BUT i got several complaints because the game didn't show a name over those new enemies and some users thought it was a bug. So i removed them.

The new reticulans can't be the source of the problems as they were introduced with 6.61. The two new weapons don't have anything "special" about them, the way they are added are the "old and trusted" way. So i think they aren't the problem either.

This would leave the only change i have done in 6.7 as the source of the bug: The rebalancing of the plasmashotguns ???? No way.

What is very disturbing to me, is the fact that Lurkers savegame shows the BOOM and SPIT weapon in the inventory screen (back in base), i designed those weapons to NOT show up there. And they don't show up on my installation, even when i use the ALLITEM cheat.

I'm out of ideas. The mod runs PERFECTLY flawless on my PC. The only thing i could propose to Lurker is to reinstall UFOAM and start a new game. See if that works. And maybe restore your Windows, too, not being able to create a new folder sounds VERY serious.

Btw, splitting the RBMOD is not possible, as several files "overlap" and need each other. Sorry!

Slaughter  or anybody else: Please report here if you have problems with 6.7, too. Atm, Lurker and Kret are my only source of information about that troubles. BlackAlmaz game seems to work, too. My UFOAM works perfectly. And i did NOT get any bug reports from other players yet. Normally my mailbox is full of them WHEN something doesn't work (like back when the cyborgs were introduced.  :( )

#38 Lurker

Lurker

    Lieutenant

  • Members
  • PipPipPipPip
  • 418 posts

Posted 10 April 2004 - 09:03 PM

Been getting Boom and Spit in inventory every time I encounter Purple Chompers (Poppers) and Purple Cudgels (Spitters), ever since they were introduced as best as I can tell.  It's just that I haven't encountered them all that much since they were introduced into the RB because I was playing at 28 bases most of that time.  Did get the occasion Purple Cudgel (Spitter) and did build up an inventory of Spit with 6.6 and 6.61.  But never really encountered the Poppers and their NO ICON inventory all that much.

Sent Aralez and Cret a saved Tactical that makes BOOM and SPIT for me on my machine with RB6.7.

My Children's Windows ME machine no longer produces Folders, but this WinXP machine of mine does in great abundance, and I get Frozen Aliens with RB6.7 on both machines, so likewise, I can't see how that could be the source of the problem.

I don't know if my install CD of Windows ME erases the drive before proceeding.  My children wouldn't be happy to have all their creations gone, but I probably should take the risk of losing it all in order to get back the Folder Options?  But from past experience, I think I could just get them back by deleting Windows Accessories and restoring them one by one until I get the right one.   WinME was always funky weird about Compressed Folders, cause it always allowed other programs to easily override the WinME default features.  WinZip and other things will wipe the default WinME handling, and if you then uninstall WinZip, the compressed folders options are gone 'forever'.  But I found that uninstalling and reinstalling Windows accessories on Drive Cleanup brought it all back to me when I got the right accessory.  I think the Nero InCD wiped out the Folders of WinMe, cause InCD is a compression tactic.  Just need to uninstall InCD and then find the right accessory to uninstall and restore, and hopefully the folders will be back.  Not a drastic thing, cause that's what WinME just does naturally, defers its folder options to anything else that wants to take control.  The joys of Windows ME.

I'll uninstall and reinstall UFO:AM on my WinXP machine.  Don't know how that will help.  I believe that all I have to do is go back to 6.61 of the RB, and suddenly my WinXP machine will be just fine for Rebalances, as it has been since February 2004.

The real potential problem is that my personal copy of UFO:AM could be incompatible with RB6.7 in some way that no other person's copy is, and in such a case uninstalling and reinstalling with the same scratched CD should probably produce the same results.  I can't put as much time into it today, as I did yesterday.  Gotta work and do stuff with family, so it will be awhile before my next tests.

--

Aralez, you describe the two new weapons as ingenious, brilliant, unique, and such, just a couple of days ago.  Unique animation of explosion, unique icons.  They sounded special or unusual to me.

There is a rumor going around that if the Effective Range is the same as the Aimed Range, then you could be looking at problems or bugs.  Both ranges are 1 meter for the TNT.  I could never figure out how to use the ALPine TNT without blowing myself up.  While running towards the enemy in order to throw it or launch it, my person gets all shot up.  And, if I do get it primed and tossed, my soldier is usually in the red and on the ground, and then then only one who dies from the TNT is the soldier carrying it.  It had no range, so I could never figure out how to use it.  And, I could never time it so that any enemy stepped on it.

When I had ALPine installed and was getting Frozen Aliens and Crashes long ago, I did have the WTD installed as a plugin, but I never got a WTD in any of my games, so I don't know as much about that one.

I just know, now, thanks to you that I really like the WTD.   :(

Before uninstalling and reinstalling UFO:AM, I'll probably go back to 6.61 on this WinXP machine just to make sure that 6.61 is still working right without Frozen Aliens.  Maybe start a new game profile with 6.61 and 115.zip and see how it goes, and see how the BOOM and SPIT build up in inventory and play out in the field.

It will take some time to try all the options and variables.  Thanks for listening and for the ideas!

#39 Aralez

Aralez

    Forum Grandpa'

  • Fan Fiction
  • PipPipPipPipPip
  • 1,670 posts

Posted 10 April 2004 - 09:39 PM

I tried your savegame and can see the inventory bug. If i try to continue with the next mission the game crashes. But this still leaves me without idea, the icons shouldn't be there, they aren't in my own savegames. It looks like a somehow corrupted savegame from an old version.

The spit weapon and the boom weapon NORMALLY will apear in the tactical missions and in the list of things that are taken back to the base, that's ok. BUT i made them so they WON'T show up in the inventory screen back in base. (This was acchieved by setting their origin to MUTANT, if anyone wants to know)

The only vague idea i have now is that maybe your gamedata.vfs file got corrupted somehow and a re-install is needed.

Btw, regarding the folder problem: Maybe you created another user-account "accidently" on that machine with very strong restrictions regarding file accessability. Try to switch to the admin account (if possible) and see if it works again. The same mistake was made by a co-worker of me and it costed me some nerves until i suddenly realized the new icon he had for his account.

Me: "Didn't you have a frog as a sign?"
Him: "Yes, that somehow changed suddenly, too"
Me: "Hmmmmmm, hey wait, i have an idea"

Changed user. Worked.  :(

I wish all problems were as easy to resolve as this. BUT i have to admit, it's pretty easy to re-create that problem and cause trouble again: Simply press the wrong button when exiting Windows and "end" your account instead. You will be asked for a name or a password then and the OS will almost look and behave the same. BUT there will be problems because you don't have admin rights anymore!

Regarding reinstalling the OS, be it ME or XP: Both OS'es give you the choice to repair your OS when you start the setup program (instead of a fresh install). They will then restore their files and don't overwrite any of your settings and docs.

#40 Lurker

Lurker

    Lieutenant

  • Members
  • PipPipPipPip
  • 418 posts

Posted 10 April 2004 - 11:44 PM

Speaking of unique:

I thought that UFO:AM weapons were limited to less than 10,000 damage.  And, I have never seen a weapon before with more than 90 meter range.  I thought that maybe there was a 100 meter limit to range.

The WTD is unique.  If the original UFO:AM was never tested or designed to handle extreme damage or extreme range, who knows what subtle glitches might appear.

The TNT and WTD were both unique in statistics.  If those statistics are incompatible with the programmer's original intentions or untested by the original programmers, who knows what's possible.

--

Windows ME doesn't have Admin that I know of, only NT and XP use the Admin and all the power and goodies and Services that the Admin feature provides.

Only using the original LogIn user on Windows ME machine.  I will have to experiment, a lot, with everything.

--

I've been getting Spit in inventory all along ever since it came into existence.  It just adds up, but ALLITEMS doesn't give it.  I think we figured out what the NO ICON item is in my inventory.  Haven't gotten as much of that since Poppers don't show up late game.

--

The SPIT BOOM tactical I sent was the result of a new game profile with no mod, and then I switched to Rebalance 6.7 on the Geoscape after a mission.  It's what happens when I RB6.7 mod an unmodded Geoscape.  That's essentially what I have been doing since 5.6.  I mod a previously saved game with a new mod.  I just sped up the process.

SPIT BOOM tactical only has the two starting bases.  It's a new game.

Okay, yet other tests for me to try.  I need to go new Game Profile created by 6.7 again after uninstall and reinstall of UFO:AM.  I imagine that will result in frozen aliens.  I believe I did already let Rebalance 6.7 create a new profile (see above), but instead of SPIT BOOM in inventory, that route leads to Frozen Aliens much more quickly.

Haven't uninstalled and reinstalled UFO:AM yet, though that WinME machine producing Frozen Aliens was essentially a fresh install of UFO:AM.

I also have to try to use that 6.7 savegame upload that you provided with a New 6.7 created Game Profile on this WinXP machine, and see if I can take off from there with 6.7.

Many things to try.

Do now believe that RB6.7 is incompatible with Spit Building up in inventory!!

--

It will take awhile to refresh or re-install OS's.  I would want to backup first, which equals time.  Uninstall and Reinstall of UFO:AM easy, but I have only the one CD, and if it's corrupted, the result should theoretically be same on every machine I use that CD on.

I also think that I have the same Nvidia Graphics Drivers and nForce Drivers on both the WinME and WinXP machines, same version numbers.  Though they are completely different files now that I think about it.  WinME and Win98 Use a different download of Nvidia Graphics and Nforce drivers from what XP uses, so they should make UFO:AM perform differently on the two machines instead of the same Frozen Aliens.  Still, if I can install UFO:AM fresh on a completely different non-nForce Win98 machine, then run RB6.7, that would be an interesting test.

It could be days or weeks.  Hopefully, others will see this and eventually join in.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users