Enemy unknown on xp


  • Please log in to reply
14 replies to this topic

#1 tanjo

tanjo

    Squaddie

  • Members
  • Pip
  • 9 posts

Posted 21 January 2004 - 06:59 PM

Just went to the faq forum , did what it said , but when on a mission it scrolls hella fast , even with scroll speed right down.

This sort of makes the game unplayable , so i was wondering was there a fix to this particular problem.

Any help appreciated.

#2 Strong Bob

Strong Bob

    Sailor Jupiter is hot

  • Members
  • PipPipPipPip
  • 567 posts

Posted 24 January 2004 - 01:52 AM

Maybe your scrolling speed is inverted. Try setting the scrollspeed to full.  :D
Strong Bob's random Star Trek quote of the year:

*Scans rock* "It's dead, Jim." - McCoy

"Very funny, Bones." - Kirk

#3 crispy

crispy

    Breakfast Cereal Champion

  • Members
  • Pip
  • 41 posts

Posted 24 January 2004 - 08:20 AM

I use X-Com Collector's Edition.  I have Win XP on a 1ghz pc, and I have fairly powerful video card.

I just reinstalled X-Com Collector's Edition on a new Hard Drive, installed the Fodder Patch (go to http://f0dder.has.it and select 'misc.';  Follow the instructions on the 'Read-Me' file, which essentially says to copy the Fodder files into the appropriate x-com folder, then make a short-cut from the new icon to your desktop for convenience).  This has fixed not only the video problems, but also the speed.  It may still run a tad fast, or sometimes a tad too slow, and may be a little buggy at times, with crashes (caused by corrupted save files?) but is otherwise great, and is easier and more convenient in many ways than other patches I tried.

I would highly recommend the fodder patch for playing UFO in XP.

#4 tanjo

tanjo

    Squaddie

  • Members
  • Pip
  • 9 posts

Posted 24 January 2004 - 05:24 PM

Cheers.

I'll give it a go and report back later.

--SOME TIME AFTER--

That fodder patch didn't even extract , i download it as a zip and when i try to extract it talks of there being no files to extract.

Even when i try to open the file it says it is corrupt/invalid.




A setback already , life is good.

#5 BladeFireLight

BladeFireLight

    Xcomutil Developer

  • Members
  • PipPipPipPip
  • 665 posts
  • Gender:Male
  • Location:Joplin, Missouri, USA

Posted 24 January 2004 - 09:32 PM

xcomutil has foders patch in it and I know it works because I use it when testing under the windows version of the game.

you can get that from Scott's Page

-Blade FireLght
QUOTE
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#6 NKF

NKF

    Mr. Badger in disguise

  • Site Staff
  • PipPipPipPipPip
  • 4,426 posts
  • Gender:Male
  • Location:In my mind

Posted 24 January 2004 - 10:09 PM

What part of the game are you having trouble scrolling in?

The Geoscape? Instead of using the globe control buttons, use the centre-on-location button instead (RMB). It's far easier to navigate with it than the scroll keys (though the scroll buttons do allow you to tip the world upside-down... :D )

If it's in the battlescape, you can switch off auto-scroll and make it so that the game only scrolls when you left click the edges. Just switch scroll speed down to 1 for good measure.

- NKF
NKF, narrow minded fuddy duddy who refuses to let go of the past and will not accept anything newer than 1979.

#7 tanjo

tanjo

    Squaddie

  • Members
  • Pip
  • 9 posts

Posted 25 January 2004 - 12:00 AM

Hahaha...

Lets now not worry about the scrolling speed right now folks.

Just opened up enemy unknown , and instead of the game appearing , a black rectangle pops up onto the screen in the top right corner , abou 300 x 250 pixels , the game running in the task bar does nothing , has to be shut down manually.


Windows is fun.

#8 BladeFireLight

BladeFireLight

    Xcomutil Developer

  • Members
  • PipPipPipPip
  • 665 posts
  • Gender:Male
  • Location:Joplin, Missouri, USA

Posted 25 January 2004 - 12:52 AM

tanjo, on Jan 24 2004, 05:00 PM, said:

Hahaha...

Lets now not worry about the scrolling speed right now folks.

Just opened up enemy unknown , and instead of the game appearing , a black rectangle pops up onto the screen in the top right corner , abou 300 x 250 pixels , the game running in the task bar does nothing , has to be shut down manually.


Windows is fun.
well that's interesting.. however it's not enough info for some of us to go from..
what are you specs and version  and what have you tried so far?

-Blade FireLight
QUOTE
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#9 tanjo

tanjo

    Squaddie

  • Members
  • Pip
  • 9 posts

Posted 25 January 2004 - 02:28 AM

Specs eh...

Windows xp pro
AMD Athlon 2500+
256mb ram
120 gig hd
geforce mx 4000 graphics card

I'm using the x-com collection edition.

#10 BladeFireLight

BladeFireLight

    Xcomutil Developer

  • Members
  • PipPipPipPip
  • 665 posts
  • Gender:Male
  • Location:Joplin, Missouri, USA

Posted 25 January 2004 - 03:03 AM

well with the gforce cards your going to need f0ders loder,  are you still having issues with that?

With thoes specs you may fair better with the Dos version using DosBox.

-Blade FireLight
QUOTE
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#11 tanjo

tanjo

    Squaddie

  • Members
  • Pip
  • 9 posts

Posted 25 January 2004 - 02:13 PM

Managed to get the fodder file downloaded and sorted , but still the black box persists with f**king up my chance of playing this game.

I;ll try to get a screenshot up of what i mean  , gonna have to download paintshop and find a picturehost , but i'll do it...

---Some further time later---

The black box has gone , the game now loads , but again is still as fast as ever. Even using trigger scroll makes the game unplayable.

The fodder patch isn't working , this could be my fault , but i am not sure.

I have copied the files from the fodder folder xcom1 , into the UFO defence folder.  Yet when i open with ldr_xcom1 the same problems persist.


Quote

Usage: copy files from "xcom1" or "xcom2" to your game folder;
which version to copy where should be obvious, I hope. The loader(s)
will look for "ufo defense.exe", "xcom1.exe", "ufo.exe" for xcom 1,
and "Terror From the Deep.exe", "xcom2.exe", "ufo2.exe" for xcom2.
If your executable has a different filename, you will have to
specify it on the commandline (or make a shortcut to ldr_xcom?.exe").
(Also, if the loader can't find any of these executables, it will
show a file-open dialog, where you can specify you executable. This
was added more or less as a last-minute change - I hope it hasn't
broken anything (probably it did, I'm tired. Sigh.)).

You can also add command-line arguments, which are needed to use
eg xcomutil. To do this, you *must* specify the executable filename
first. Ie, do something like "ldr_xcom1 ufo.exe 1". The loader will
wait for the game to finish before terminating, so you can use this
from batch files and such.

If the loaders for some reason don't work, tell me:

*) any error messages the loader might spit out
*) the name of your XCOM executable file
*) any other 'interesting behaviour'

That is the faq , makes very little sense to me but i gave it the best go i could.

#12 BladeFireLight

BladeFireLight

    Xcomutil Developer

  • Members
  • PipPipPipPip
  • 665 posts
  • Gender:Male
  • Location:Joplin, Missouri, USA

Posted 25 January 2004 - 06:23 PM

the only version of f0ders loader I have used is the one that comes with xcomutil, however with my 2700+ cpu the game is OK in tactical but way to fast in Geoscape, to the point I consider unplayable. and spining the globe is like 0 to 10000 mph in a nano second,  my solution was runing the Dox version in DosBox.

Most of the players that play with the windows version on a fast computer use the right mouse button to turn the globe, and have to be quick on the mouse to catch ufo's because they all are fast moving, (all tho there is a patch to make that part slower)

So, to sum up, if your problem is the scrolling of the globe in geoscape your SOL.

Not what you wanted to hear but I'm sure the rest will agree.

-Blade

ps, you can buy the dos version of x-com here and get DosBox here
QUOTE
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#13 tanjo

tanjo

    Squaddie

  • Members
  • Pip
  • 9 posts

Posted 25 January 2004 - 07:34 PM

Geoscape is fine on my version , just the actual missions.

Can't see myself paying for a new copy of a game i shelled out 20 quid for a few months back.

Is it justified that due to my ownage of a copy , i can download a free copy in the most unlegal way ?

#14 crispy

crispy

    Breakfast Cereal Champion

  • Members
  • Pip
  • 41 posts

Posted 27 January 2004 - 04:30 AM

When playing the actual missions, did you reduce the speed in the settings?  One of the buttons at the bottom of the screen (on the mission screen that appears after your troops have landed) controls settings such as scroll speed, alien speed, firing speed, etc.  (it's been a while since I looked at it, so I don't remember exactly what all is there, but I've used it a time or two when, in spite of the fodder patch, my game still ran too slow or too fast.)

The fodder patch still works okay for me though.  Could be your machine has a more powerful video card than mine, though my card's not bad.  When all else fails, you could try turning down the video accelleration, but ... try the game scroll settings on the mission screen first.

#15 tanjo

tanjo

    Squaddie

  • Members
  • Pip
  • 9 posts

Posted 27 January 2004 - 04:09 PM

The scroll speed is at the lowest possible setting , that isn't the solution.

And i turn off video accelleration before i play x-com as otherwise it would not run at all.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users