XCOM - Keyboard Doesn't work.


  • Please log in to reply
10 replies to this topic

#1 nerdbebo

nerdbebo

    Squaddie

  • Members
  • Pip
  • 5 posts

Posted 09 December 2003 - 02:42 AM

Sooo... I'm read through all the support forums looking for help on this, haven't seen anything yet. Maybe someone out there ran across this problem and was able to solve it? We'll see.

Basically... the game runs great... sound, video, mouse... the works. One problem. The keyboard doesn't work at all. I've tried all the compatibility stuff built into XP and i've tried the Patch everyone has been talking about.

Basically... When I create a new game, it asks me to name the base... I get nothing. It won't let me type at all.

Ideas?

Windows XP Professional
P3 1000mhz
GForceFX 5200
On Board Audio
Normal PS/2 Keyboard.

Thanks in advance.

-Dave

#2 NKF

NKF

    Mr. Badger in disguise

  • Site Staff
  • PipPipPipPipPip
  • 4,423 posts
  • Gender:Male
  • Location:In my mind

Posted 09 December 2003 - 06:38 AM

I've had this problem several times before too (and not just with any of the X-Com games). Though most of the time the cause and solution were a bit elementry (the keyboard plug had come loose - tightening the plugs fixed it). At other times the computer just needed a good reboot.

What version of the game are you using? The dos edition or the collectors edition (i.e. the windows version)? If you run the game with an .exe, it should be the windows version, if you run it with a .bat (or .com) file, then it's the dos version.

- NKF
NKF, narrow minded fuddy duddy who refuses to let go of the past and will not accept anything newer than 1979.

#3 nerdbebo

nerdbebo

    Squaddie

  • Members
  • Pip
  • 5 posts

Posted 09 December 2003 - 02:47 PM

I'm using the Windows Version, and no my keyboard is not messed up, because it works in other games/windows. This is the only game I have that has this problem.

Thanks.

-Dave

#4 Ego Terrorist

Ego Terrorist

    Leader of the "We love Tammy" Club

  • Members
  • PipPipPipPip
  • 193 posts

Posted 09 December 2003 - 08:15 PM

hmm..

So you're not able to enter data into the game? (Such as base names, character names etc)

And you're not able to use the keyboard shortcuts (Assuming that UFO has 'em)

But are you able to use the 'window's' button  (located between Ctrl and Alt)?

Is there anything special about your keyboard, did you install any drivers for the keyboard? Also are you able to Alt-Tab and use the Keyboard outside of UFO while it is running?

Just a few questions to help us figure out this problem :D
Dammit I just misspelled on my christmas present list...now I've asked satan for an inflatable Buffy.

Leader of the "We love Tammy club!"




#5 nerdbebo

nerdbebo

    Squaddie

  • Members
  • Pip
  • 5 posts

Posted 09 December 2003 - 11:42 PM

Normal keyboard... no special drivers. The window key works... ctrl-alt-del works... but within X-com it doesn't let me input anything.

Ideas?

#6 nerdbebo

nerdbebo

    Squaddie

  • Members
  • Pip
  • 5 posts

Posted 09 December 2003 - 11:47 PM

One more thing, I just tried it on my laptop across a network drive and the same problem occurs. Hope that helps.

-Dave

#7 nerdbebo

nerdbebo

    Squaddie

  • Members
  • Pip
  • 5 posts

Posted 12 December 2003 - 07:01 AM

Bump, any ideas?

#8 Hecatonchire

Hecatonchire

    Squaddie

  • Members
  • Pip
  • 1 posts

Posted 05 March 2012 - 11:50 PM

Hello nerdbebo,


I see this post has been unanswered for a while bit I just came across the same situation and managed to fix it. I hope this may help you or further X-Com players with the same issue:

I re-installed TFTD (CE Edition) this weekend (this is not the first time that this has happened) and applied all the necessary patches (...but this is another topic). Howewer it was still crashing right after the intro.

Since I had already seen this problem before (due to a prior X-Com relapse on another computer) I assumed I had missed something with the patches).
So I tried another crazy thing by switching my langage option to english in-game (since I am french it wasn't my natural choice - nevermind, it's probably better worded in O.V.) and then reached the main menu and even got proposed to pick a location for my first base!

But then I got that issue you depict. I have actually changed two things so I can't tell which one made the difference (poor experiment design, I agree), still my likes go to the latter:

    -I have connected a bluetooth mouse my laptop (Dell Vostro 1510 / Intel Core 2 Duo T83000 2.40Ghz, 3Go RAM     / XP Pro SP3) because (1) I 'd rather use the mouse indeed but also (2) wondered if the trackpad wasn't creating some sort of conflict (but I don't know what I am talking about ^^)

    -I changed the regional settings to english (and windows had me reinstall some files from the CD) because I figured there might be something about the way charachters are coded (don't know much about that either).

So for now it seems to work (haven't tried to manage the base(s) or the tactical phase yet) with a qwerty keyboard (most of you can picture themselves with an azerty one and many subtle but potentially nasty swaps).

I don't know if that will help, I hope so, you may find your way around within the above lines.

Best,

H.

P.S: Sorry for the blah blah and the not-so-precise solution I suggest but now I have an alien invasion to contain! :blush:

#9 Space Voyager

Space Voyager

    I've got my eye on you!

  • Site Staff
  • PipPipPipPipPipPip
  • 5,394 posts
  • Gender:Male
  • Location:Slovenia

Posted 06 March 2012 - 06:54 AM

Interesting how people still find solutions to almost a decade old problems.

[sparta]This... is... X-COM!!![/sparta]

#10 NKF

NKF

    Mr. Badger in disguise

  • Site Staff
  • PipPipPipPipPip
  • 4,423 posts
  • Gender:Male
  • Location:In my mind

Posted 06 March 2012 - 07:25 AM

Sad thing is, it's still different strokes for different folks. Some fix it by switching off the keyboard language support (that EN thingy or whatever language it's set to on the task bar), or just plugging in a plain PS2 or USB keyboard (not sure if anyone remembers AT/XT?). Some fix it by just playing the dos version and let Dosbox handle keyboard recognition. :blush:

- NKF
NKF, narrow minded fuddy duddy who refuses to let go of the past and will not accept anything newer than 1979.

#11 Sgt. Strike

Sgt. Strike

    Seeker of truth, and also to kick some alien butt!

  • Members
  • PipPipPipPip
  • 309 posts
  • Gender:Male

Posted 06 March 2012 - 07:48 AM

X-Com UFO Defense Windows CE does have issues with some keyboards. Try a few things. First, reinstall the game. That may fix it. Second, If that doesn't work, then try drivers for the keyboard. Third, ensure that the game is installed on your main drive, and not a secondary or even a network drive. This might cause some problems as well. Fourth, check the compatibility of the game. This maybe why the keyboard isn't working. One last thing, try a different keyboard.
When all else fails, CHEAT!!!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users