X-Com 2: Terror from the Deep - Vista Problem


  • Please log in to reply
7 replies to this topic

#1 Balth

Balth

    Squaddie

  • Members
  • Pip
  • 6 posts

Posted 31 October 2012 - 07:13 PM

I installed Collector's Edition of TFTD in my Laptop (Vista, Dual-Core) but when i try to play the game, it loads to a black screen and then hangs. If I Alt+Tab out and then reopen it, i get an error message and games closes.

Same problem with UFO 1 (I don't want to play UFO 1, just wanted to test if the same problem will appear). Although in UFO 1 the music plays!

I tried TFTD to a P4 one-core with XP and it works fine.

If i try to open the game using the TFTD Extender, this message appears:
Posted Image

I want to really try this TFTD Extender here: http://www.strategyc...-tftd-extender/
It seems very good!

Anyone knows how can i make TFTD work in my Laptop?


P.S: Is TFTD Collector's Edition patched to ver. 2.1 or do i have to apply the patch?

#2 Bomb Bloke

Bomb Bloke

    The Smily Admin

  • Admin
  • PipPipPipPipPip
  • 4,625 posts
  • Gender:Male
  • Location:Tasmania (AU)

Posted 31 October 2012 - 09:16 PM

Download and extract XcomUtil into your game folder. Go into the XcomUtil folder now in your game directory, into the Patches folder in that, and run the two EXEs you see in there (Xcom Vista Patch.exe and XcomUtil UAC Fix.exe).

After that, run the game "normally" and see what happens, then try with Extender.

You don't need the 2.1 patch, the CE version is the latest.
BB's X-Com Projects Page - X-Com Games At GamersGate
You're just jealous 'cause the voices only talk to me :P
We love Tammy! :)

#3 Balth

Balth

    Squaddie

  • Members
  • Pip
  • 6 posts

Posted 31 October 2012 - 09:29 PM

View PostBomb Bloke, on 31 October 2012 - 09:16 PM, said:

Download and extract XcomUtil into your game folder. Go into the XcomUtil folder now in your game directory, into the Patches folder in that, and run the two EXEs you see in there (Xcom Vista Patch.exe and XcomUtil UAC Fix.exe).

After that, run the game "normally" and see what happens, then try with Extender.

You don't need the 2.1 patch, the CE version is the latest.


Ok. i did as you said. The problem remains.

Any ideas?

#4 Bomb Bloke

Bomb Bloke

    The Smily Admin

  • Admin
  • PipPipPipPipPip
  • 4,625 posts
  • Gender:Male
  • Location:Tasmania (AU)

Posted 31 October 2012 - 10:35 PM

Hmm. Let's assume it's something to do with the video mode it wants to use versus your video card. What if you enable Extender's DirectX tweaks?
BB's X-Com Projects Page - X-Com Games At GamersGate
You're just jealous 'cause the voices only talk to me :P
We love Tammy! :)

#5 Tycho

Tycho

    Lieutenant

  • Project Staff
  • PipPipPipPip
  • 703 posts
  • Gender:Male

Posted 31 October 2012 - 11:50 PM

Check the Extender INI and ensure that:
D3D=1
D3D Windowed=1
Skip Intro=0

Edited by Tycho, 01 November 2012 - 03:08 AM.


#6 Balth

Balth

    Squaddie

  • Members
  • Pip
  • 6 posts

Posted 11 November 2012 - 01:24 PM

View PostTycho, on 31 October 2012 - 11:50 PM, said:

Check the Extender INI and ensure that:
D3D=1
D3D Windowed=1
Skip Intro=0

Ok. thanks! :)
I did these and the game now works fine. Few crashes here and there but nothing serious.

By the way, this only works with TFTD Extender. If i try XcomUtil, game still has problems.
XcomUtil has some nice features, especially the "Save soldiers equipment configuration"! This is a HUGE time saver!
Any idea how i can combine Extender and XcomUtil?

#7 Tycho

Tycho

    Lieutenant

  • Project Staff
  • PipPipPipPip
  • 703 posts
  • Gender:Male

Posted 11 November 2012 - 08:51 PM

the latest patch for Extender allows you to save equipment configurations.  Enable "save equipment" under the [equipment] section of the INI.

#8 Bomb Bloke

Bomb Bloke

    The Smily Admin

  • Admin
  • PipPipPipPipPip
  • 4,625 posts
  • Gender:Male
  • Location:Tasmania (AU)

Posted 13 November 2012 - 10:20 AM

I posted a patch for XcomUtil that allows it to be used in conjunction with Extender in the first post of this thread. Extract it into your game folder then run XcomUtil's setup batch again.
BB's X-Com Projects Page - X-Com Games At GamersGate
You're just jealous 'cause the voices only talk to me :P
We love Tammy! :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users