ck07's Content

There have been 17 items by ck07 (Search limited from 01-November 19)


By content type

See this member's

Sort by                Order  

#103010 X-COM UFO Defense, CE, DOS, can't equip for mission

Posted by ck07 on 19 March 2011 - 08:16 PM in Support

 Bomb Bloke, on 19th March 2011, 3:46am, said:

So it's doing the same thing as before. I hadn't tested it in DOSBox before myself, but now that I do, it seems to be working; just a guess, but did you maybe extract my archive INTO the MISSDAT folder (as opposed to over it)?

Extracted MISSDAT and your tools to separate directors, then re-ran the failed mission (which of course failed again), then saved the game, then copied _TacResume into the XCOM directory and your MISSDAT over mine, then opened DOSbox and mounted the directory, then ran _TacResume.

Is that  the (or a) right sequence?



#102955 X-COM UFO Defense, CE, DOS, can't equip for mission

Posted by ck07 on 18 March 2011 - 02:36 PM in Support

 Bomb Bloke, on 17th March 2011, 9:14pm, said:

I don't like storing the game (or any OTHER game) in Program Files for the simple reason that it takes too long to find stuff in there. You can move the game to c:\games\xcom or something if you like.

Later versions of Windows specifically have problems with running many games from Program Files. XP should be fine with it though, if you really wanna leave it there.

If the path has spaces in it, you'll need to wrap quote tags around it. A sample set of commands would be:
You're probably right about where to put applications.  I used to be better about it.

Some progress:
-Went back to before UFO-40, let it start and fail, copied your MISSDAT into place.
-Managed to mount c: properly and to start _TacResume (had to truncate name).
Result: Black screen in DOSBox window, cursor in upper left, DOSBox apparently frozen.

Don;t know whether this is just hard or I am doing it wrong; either way I apologize for taking up your time.



#102937 X-COM UFO Defense, CE, DOS, can't equip for mission

Posted by ck07 on 18 March 2011 - 12:03 AM in Support

Ah.  Removed my DOSBox 0.65 months ago, so didn't have one (apart from the one that is part of CE).

Installed 0.74.  Have a Z: prompt.  Can't run _TacResume.bat because "drive C: is not mounted."  

Read the instructions for the MOUNT command.  I assume that what I need to do is something like "MOUNT [some letter] C:\Program Files\X-Com\X-Com UFO Defense\XCOM" (the dir where tactical.exe and _TacResume are).

Then I would issue "[that letter]:\_TacResume"  

Is this right?

The DOSBox documentation, however, warns against mounting the C:\Program Files directory or any part of it due to risk of corruption of the actual hard disk.

Advice?  

Thanks for your patience.



#102932 X-COM UFO Defense, CE, DOS, can't equip for mission

Posted by ck07 on 17 March 2011 - 10:45 PM in Support

Got partway there.  Reached the equip screen although graphics resolution was greatly reduced (640 > 320?) and mouse movement very fast--basically uncontrollable .

Hit a key to see what would happen next.  Turn 1 appeared, again with altered graphics and fast mouse.

Next key/mouse click touched (tried both ways) caused this error message:

C:\WINDOWS\system32\cmd.exe
The NTVDM CPU has encountered an illegal instruction.
CS:0000 IP:00ba OP:0f 04 50 09 9c

Task Manager showed these running:
cmd.exe
16 bit MS-DOS Subsystem

Read _TacResume.bat in Notepad.   I do have a directory called UFOEXE that contains a file called BLACK.exe.  (And I do have split .exe's courtesy XComUtil.)


FWIW I attempted to reload the game the regular way, from just before the Djakarta/UFO-40 mission.  When I reached UFO-40 got same empty equip screen, but when I hit a key it failed in a way I have not seen before--left two dosbox windows open.  One was labeled TACTICAL but was empty, the other was labeled DOSBos Status Window and contained:

CONFIG:Loading primary settings from config file dosbox.conf
MIDI:Opened device:win 32.



#102925 Clips

Posted by ck07 on 17 March 2011 - 04:43 PM in Support

After reading the UFOpaedia and the   XComUtil 9.7 documentation, I am still unclear on what is supposed to happen  to clips.  I understand it as:
-Loaded clips, rockets, stun bombs, and blaster bombs--but not HWP shells or rockets--are used up whether full or not;
-Unloaded [same items] are not used up.
But  careful accounting of c. 5 missions--including unloading every alien  weapon (except sometimes, FOR, the last killed)--does not always agree  with this.



#102924 X-COM UFO Defense, CE, DOS, can't equip for mission

Posted by ck07 on 17 March 2011 - 04:41 PM in Support

 Bomb Bloke, on 17th March 2011, 8:08am, said:

For who knows what reason the terrain type is set to 63993 (or 0xF9F9) - it's only supposed to go up to 9, tops. Likewise, the map module table is a complete mess.

When you go to start a mission, the game checks the WORLD.DAT entry for the geoscape polygon the battle is to take place in, and sets the GEODATA file accordingly. It would appear the polygon in concern has an invalid terrain type set, but this should also cause the game to have issues displaying the geoscape, so I reckon something else may be going on here. Dunno. I may dig into it a bit more later, but for now I've generated a new GEODATA file, tweaked the UNIPOS file to match, and repackaged the result. Should get you through the mission, it'll be interesting to see if the weirdness persists.

To use this, you'll need to extract it back into your game folder, then extract my toolkit over that (refer to my signature). I'm assuming you're using the DOS version of the game, so you should then be able to just run "_TacResume.bat" and things should continue from there; if it is CE, you'll need to split your executable first ("_EXE Split.bat" can do that for you, but you'll need the Java VM installed to run that one; odds are you've already got it anyways).

MISSDAT.rar

Thanks!  I'm using the DOS component of the CE package plus XComUtil 9.7 (I hope that XCU is not the cause of the problem).  

Xcusetup did split the .exe file but I'm unclear on whether that matters for the DOS version.  (Have been unable to use Win version under XP SP3--f0dder's loader works but I get strange colors plus a hyperactive clock.  Understand that  CPU-slowing utilities deal with the latter, but lack solution for the colors.)

I'll try your files when I get home.  

(I see that you enabled .rar files.   :laugh: )



#102904 X-COM UFO Defense, CE, DOS, can't equip for mission

Posted by ck07 on 17 March 2011 - 02:40 AM in Support

 Bomb Bloke, on 16th March 2011, 6:04pm, said:

You can right click the folder and select "add to archive...", which will grant the option to zip it. Or I suppose I could stop being lazy and enable RAR uploads.

Did not know that WinRar could make .zips.  Thanks.

Quote

When the game attempts to start a mission, it makes a full save to the MISSDAT folder, replacing most of what's in there. Copying another save in there won't work as it'll just overwrite it again when you try to start the mission again.

Actually doing this did change the behavior somewhat.  I was able to re-run the Tokyo mission (UFO-37; 38 and 39 were shot down) and then the second of the battleships (in order of appearance; UFO-41), which this time landed at Manila.  But when I went after the one at Djakarta (UFO-40) the same bug recurred--with the minor difference that you would have predicted, namely that the results shown were those for Manila.

Since the problem occurs after different tactical missions, but at the start of the same mission (and regardless of which of two Skyrangers I use for that mission), it must be a property of the Djakarta mission.  When both battleships land at Djakarta (UFO-40 always lands first) it affects both missions.

(Would be a juicy mission if I can play it.  #5 of 5 to stop an infiltration plus Snakemen = mucho reactions training.)

Attached Files




#102892 X-COM UFO Defense, CE, DOS, can't equip for mission

Posted by ck07 on 16 March 2011 - 05:42 PM in Support

 Bomb Bloke, on 16th March 2011, 9:21am, said:

It's worth noting that whenever the tactical game engine exits, it's supposed to write the mission results to the HDD for the geoscape engine to follow up on. If the tactical engine crashes, the results for the last mission stay on the drive, so the geoscape engine reads that.

That is to say, if the last mission you played through was Tokyo, then if the tactical engine crashes later it would be normal to see mission results from Tokyo.

First, thanks for being willing to look at this.  

Agree that the re-appearance of the Tokyo results, given the main problem, is not surprising.  There is a UFOpaedia discussion of an exploit that makes use of this.

Quote

This can cause havoc, but reloading to a save prior to the crash should sort it.

Now I'm not sure which 'crash.'  There was no crash in/after the Tokyo mission, and there was a save after it (also one during and one not long before).   None of these saves would let me get past the equipment screen at Djakarta, although the earliest, combined with a still earlier craft.dat, got different results which are described above.

Quote

In any case, start your mission, allow the game to crash again, then zip up your MISSDAT folder and post it here. I might be able to work out what it's choking on, or perhaps one of my game versions will happily start the mission.

Hmm.  I have WinRar but this BB will not allow an upload of a .rar.  Suggestion?

A few minutes later--I tried reloading from a still earlier save.  Got a different landing location for one of the battleships and tried running Djakarta before Tokyo.  Same problem.  Which tells me that you are right that the problem is in the MISSDAT folder, not in the savegame(s).  I notice that many of the filenames are the same.  Would it be crazy to copy a savegame folder over the current MISSDAT?



#102871 X-COM UFO Defense, CE, DOS, can't equip for mission

Posted by ck07 on 16 March 2011 - 07:00 AM in Support

More data.

Went back to before the Tokyo mission; 3 Skyrangers in the air.  Had the one aimed at Tokyo  stop to patrol so that one of the Djakarta missions would arrive first.  When it did, same behavior of equipment screen PLUS when I pressed a key I got a mission result: 7 aliens dead, 11 X-COM (all), plus craft.  When I returned to Geoscape, one Skyranger and crew had vanished.  Not the one that I could not equip -- the one that had been near Tokyo disappeared even though it had never gotten closer than a few hundred miles; I had left it patrolling out at sea.

This is getting weird.



#102870 X-COM UFO Defense, CE, DOS, can't equip for mission

Posted by ck07 on 16 March 2011 - 06:48 AM in Support

More data:

Tried replacing craft.dat with (3 different) earlier versions.  This caused the two Skyrangers aloft to lose track of their missions, so I re-tasked them.  Same ultimate result.



#102869 X-COM UFO Defense, CE, DOS, can't equip for mission

Posted by ck07 on 16 March 2011 - 06:24 AM in Support

50+ missions worked in 3 games before this.

Alien inflitration, Southeast Asia, 5 ships.  Shot down 2, interceptors on way home (none minimized).  Sent my three Skyrangers after the other three on the ground.  Successfully defeated the first (large scout, Tokyo).  Other two are battleships on ground at Djakarta, each targeted by a different Skyranger.  When 1st Skyranger reaches its target, I get to the equipment screen but it is black with cursor in upper left.  Pressing any key or button re-displays result screen for the Tokyo mission.

Inserting a fresh savegame in between does not help.

Repeating the last part of the Tokyo mission does not help.

Diverting the first Skyranger, then re-assigning, does not help.

Divert the 1st Skyranger so that the other will arrive first does not help.

It seems clear that I have a corrupt file in my savegames during/after/maybe before? the Tokyo mission, but I need help in identifying which file(s) and what to do about them.



#102095 Base disappears when a diffirent base lost to aliens

Posted by ck07 on 19 February 2011 - 03:21 AM in Support

Have not found this one in any of the bug FAQs or known bug lists.

CE, DOS version, via Dosbox 0.72 under XP SP 3.

Beginning of May.  I detect a Battleship coming in to attack my #3 base (in China).  Unfortunately it is defenseless; its first soldiers and Skyranger were purchased just before the end of April.  I transfer out most everything, sell the rest.

When the base falls undefended MY #1 BASE ALSO DISAPPEARS at the same instant--or rather, it disappears from the map and loses all its personnel, aircraft, and stores.  Clicking on it on the base screen shows it to be supposedly located in the same region as my #4 base but it cannot be found on the Geoscape.   (Base screen also shows layout unchanged but facility count is wrong--same as the much smaller base #3 that was lost.)

I thought that this might be connected to all the stuff that was in transit from #3 to #4, so I tried again, this time selling everything instead of transferring.  No change except that the nominal region of the missing base #1 is now that of #3 instead of #4.

I think that this must be somehow connected to the Skyranger and 12 soldiers who were pending delivery at base #3 when it fell.

Going back and not ordering them would be too awful--I would lose three missions that took 8 hours or so.

I read about replacing one data file with the version from another save in order to eliminate ufo's in flight but I am reluctant to try that for fear of making a worse mess.



#102094 Problem with f0dder's loader (CE, Windows XP SP 3)

Posted by ck07 on 19 February 2011 - 03:06 AM in Support

The loader works but produces altered colors and what I'll call an 'agitated' screen--e.g., the yellow arrow above the current soldier bounces up and down x 5-15 / second.  Not, as far as I can tell, the same as flicker.



#102093 Utility + Extender = FAIL

Posted by ck07 on 19 February 2011 - 03:01 AM in Support

View PostBomb Bloke, on 13th February 2011, 4:51pm, said:

There'll be "UFO Defense.exe" and "UFO Defense_Patched.exe". If neither works, then give more info on what happens instead.

Savegames between Windows/DOS should be compatible. You can start using XcomUtil midway through a campaign.
Thanks!
-CE, purchased from Gamersgate 12/2010.  XP SP 3.
-I managed to install XComUtil--sort of: I copied the whole business to the correct directory this time.  Xcesetup patched the Windows (XP SP 3) version--including splitting it into two parts as promised--but, as far as I can tell, not the DOS.   (I am unclear whether the DOS executable and the (unmofied) Windows .exe are the same--to run the DOS, I start a 3 meg. DOSbox file which either contains or starts the executable, I cannot tell which.)
-Can't actually run XComutil.  Cannot run it from the Windows command line because there is both an xcomutil .exe and an xcomutil directory (containing data files) in the same folder.  I created a small .bat to run it from the same directory.  Contents: "xcomutil game_2 wrt"  Did not get the acknowledgement message though and the savegame was not modified.  Dunno what that is about.
-Am also experiencing a problem with f0dder's loader and a gameplay bug but will create separate threads for those.



#101852 DOS vs Windows version?

Posted by ck07 on 13 February 2011 - 06:55 PM in Enemy Unknown

View PostCapnKill, on 8th July 2010, 6:09pm, said:

Stumbled up this thread on Steam: http://forums.steamp...d.php?t=1146530

Looks like the windows version is there and can be used, plus the mods and the better music sounds like the perfect way to play.  I'm going to give this a shot tonight and see what I think.  

I'm most excited about the "open door without having to walk through it" fix.


Is this the same as X-COM CE from Gamersgate?  Comes with a 7,000 KB dosbox version (works) and a 442 KB windows version (which I can't figure out how to run).



#101851 Infiltration, am I screwed?

Posted by ck07 on 13 February 2011 - 06:51 PM in Enemy Unknown

Out of the 5 alien ships in an infiltration mission, how many do you have to stop to make the mission fail?


I've seen that 1/5 is not enough.  Just did 3/5 in about 12 hours (that Skyrangers probably needs some serious maintenance) but what I do in the remainder of the month depends a little on whether 2 surviving infiltrator ships still succeeds for them. 



#101850 Utility + Extender = FAIL

Posted by ck07 on 13 February 2011 - 06:34 PM in Support

A long-ago veteran, I am re-discovering the enjoyment after 12-13 years.  

One technical Q (X-COM Complete (from Gamersgate, I think), running on XP-32 SP 3).

For UFO Defense, dosbox works.  Also see what looks like a Windows executable in X-COM UFO Defense directory, but clicking on it does not work and cannot figure out which--if any--of the other files is the launcher.   

Can someone explain?  With that I think I could implement the bug fixes mentioned in this forum and others.

Btw, can dosbox savegames be loaded inthe Windows version?  Also, can savegames made without XCOMUtil be loaded with it?

Thanks.