ALPine

Description

ALPine provides a system for "plugin" style modding for the game UFO: Aftermath by ALTAR Interactive. By creating mods as ALPine plugins, multiple mods can be applied to the game at once.

ALPine features a Graphical User Interface for players to select and apply the plugins they wish to use, and a Plugin Installer to simplify adding new plugins.

With this version, ALPine no longer brings up any console windows when it's processing plugins.  It's less annoying, looks better, and you can leave it in the background and view other windows if plugin processing is taking a while.

A few other changes:
The Mod Wrapper now supports mods with names "mod*.vfs" as well as "*cfg.vfs".
The GUI layout has been changed to better use the space.

ALPine 3.0 requires UFO: Aftermath version 1.3.


File Details

Filesize 569 kB
Author Fulby
Version 3.02
Downloads 3,385

File Mirrors

Mirror ALPine documentation

 

Add Comment Comments

Grufflehound\
29 Jan 2016 - 2:48am
Grufflehound
There are problems with the Steam version but I then tried running the GOG version and no problems running Alpine there whatsoever.
tomas352000\
23 May 2014 - 5:08pm
tomas352000
i was thinking, it could be because of wrong name of the main .exe file, so, whats the basic name?
tomas352000\
23 May 2014 - 2:30pm
tomas352000
hey, i tried to install alpine, but everytime i try to install i just recieve message UFO Aftermath was not found, can someone help me with that?
Slaughter\
25 Aug 2008 - 6:17pm
Slaughter
You mean the music mod for ALPine? If there was one, it was likely the same as this standalone one: http://www.strategyc...dex.php?dlid=57

Guess I saw no reason for having both in the files section. As for the parameters, I don't know sadly. Should have been documented with the readme of the mod, as Fulby usually documents things well.
Red\
25 Aug 2008 - 5:04am
Red

Slaughter, on 24th August 2008, 8:28am, said:

It's been a while since Fulby was around, so you should try to PM/e-mail him. As for the mod, I might have it somewhere, but not sure which one that is. There is a musicmod in the files section I believe?
Thanks for the Reply anyways. I tried PMing him or E-mail but your System Won't Let me.

Checked the Files Section http://www.strategyc...ndex.php?cid=37
It's not there, and I have searched ALL of it. the search gave me X-Com Music Mod and the Tampa_Gamer Sound Effect Mod (UFO: AL)

About the Parameters?

and the Parameter of FoV? is it in Percentage % 1-100% or Degrees from 70° to 140° to 180° or 360°? or 1-10?
Slaughter\
24 Aug 2008 - 12:28pm
Slaughter
It's been a while since Fulby was around, so you should try to PM/e-mail him. As for the mod, I might have it somewhere, but not sure which one that is. There is a musicmod in the files section I believe?
Red\
24 Aug 2008 - 8:55am
Red
And the other Plugins in the ALPine 3.0.2
= Does this mean IF the Parameters isn't mentioned we should keep it at Zero Value?
= Whats the Original FoV Parameter? is this Fog of War?
= http://www.thefall.n...th/musicmod.zip IS NO Longer exist?


Applying Plugins...
Processing * Mod Wrapper...
Processing Tactical Mission Camera Modes...
Processing Helicopter Speed...
Processing More Recruits...
Processing Hostile Humans...
Processing Stun Rod...
Error processing: plugins\stunrod.lua
Lua Error: code\files.lua:135: attempt to concatenate field `?' (a nil value)
stack traceback:
	code\core.lua:291: in function `alpine_error_handler'
	code\files.lua:135: in function `saveitems'
	code\items.lua:71: in function `addmagazine'
	plugins\stunrod.lua:7: in main chunk
Processing TNT...
Error processing: plugins\tnt.lua
Lua Error: code\files.lua:103: file is already closed
stack traceback:
	code\core.lua:291: in function `alpine_error_handler'
	[C]: ?
	code\files.lua:103: in function `loaditems'
	code\items.lua:55: in function `addmagazine'
	plugins\tnt.lua:5: in main chunk
Processing Extended Magazines for UZI...
Error processing: plugins\uziex.lua
Lua Error: code\files.lua:103: file is already closed
stack traceback:
	code\core.lua:291: in function `alpine_error_handler'
	[C]: ?
	code\files.lua:103: in function `loaditems'
	plugins\uziex.lua:12: in main chunk
Processing Warp Bomb and WTD...
Error processing: plugins\wtd.lua
Lua Error: code\files.lua:103: file is already closed
stack traceback:
	code\core.lua:291: in function `alpine_error_handler'
	[C]: ?
	code\files.lua:103: in function `loaditems'
	code\items.lua:55: in function `addmagazine'
	plugins\wtd.lua:5: in main chunk
Finalising...
Finished processing plugins
NO IDEA what's the Problem? does this mean We cant use the ALPine Equipment? and that we can't use them?
Applying Plugins...
Processing Extended Magazines for UZI...
Processing Stargate Staff Weapon by Red Otter...
Processing Stargate ZAT (Zat'n'kitel)  by Red Otter...
Processing * Mod Wrapper...
Processing Tactical Mission Camera Modes...
Processing Helicopter Speed...
Processing Field of View...
Processing More Recruits...
Processing Hostile Humans...
Processing Psionic Mutant...
Processing Blood Patch...
Processing One-Handed SMGs...
Finalising...
Finished processing plugins
Red\
4 Apr 2008 - 12:13pm
Red
Since the ALPine website is DOWN.

the Other *.Alp Mods MUST be Run BEFORE
you [ APPLY ] the Lua Plugin Engine 3.0.2?
After you install ALPine.

Wondering HOW to operate the Mod Wrapper?

the [ mods readme.txt ]
C:\Program Files\CENEGA\UFO Aftermath\ALPine\plugins\mods
See "1mod readme.txt" for general information on this plugin.


Adding mods to the Mod Wrapper

Create a sequence of directories called modX in the plugins\mods directory, where X is a number starting from 1.  Place each mod's "*cfg.vfs" or "*mod*.vfs" file and "LocalizationPack.vfs" file in one of the plugins\mods\modX directory.

For example:
Make directory "plugins\mods\mod1"
Copy the VFS files from the first mod into it.
Make directory "plugins\mods\mod2"
Copy a second mod's VFS files into it.
We need to place each Additional Mod in a Folder.
C:\Program Files\CENEGA\UFO Aftermath\ALPine\plugins\mods\mod1
C:\Program Files\CENEGA\UFO Aftermath\ALPine\plugins\mods\mod2


Using ALPine, 68_mod & combo_beta ALL together is OK?
Applying Plugins...
Processing * Mod Wrapper...
Error processing: plugins\1mod.lua
Lua Error: plugins\1mod.lua:18: attempt to concatenate local `cfg' (a nil value)
stack traceback:
	code\core.lua:291: in function `alpine_error_handler'
	plugins\1mod.lua:18: in main chunk
Means that the Mods weren't Placed in the Proper Folders and Wasn't able to merge it with ALPine.
Fulby\
30 Apr 2004 - 6:33am
Fulby
Good to hear it's working :(

Fulby
CommChe\
30 Apr 2004 - 1:52am
CommChe

Fulby, on Apr 29 2004, 01:56 PM, said:

What version of Windows are you using?

What is the path UFO:AM is installed to?

Is the RB mod placed in "ALPine\plugins\mods\mod1"?
Please check the exact path, i.e. \mods\ not \mod\

Do other mods work with the mod wrapper?
Hi fulby

I'm using WIN XP pro with SP 1.

UFO AM is c:\CENEGA\ufoaftermath

No!  :( the RB mod was not in that dir.

After creating some dirs and placing the appropriate vfs files in them, I ran the alpine program and IT ALL WORKED   :(

Applying Plugins...
Processing * Mod Wrapper...
Processing Tactical Mission Camera Modes...
Processing Blood Patch...
Processing Geomarks (Craft colour)...
Finalising...
Finished processing plugins

I should have explored more and read all of your helpful readmes. Thanks mate for your help. And you are doing an absolutely fantastic job with making AM closer to what it should have been. You, slaughter and aralez should be on the dev team for sure!  :(

and all of you guys for that matter.
Aralez\
29 Apr 2004 - 7:47pm
Aralez
@BlackAlmaz: I tried to increase the number of aliens in 1.3 the way the mentioned modder did it and had no success. 22 was the maximum i could achieve (that's the normal number in hard). Btw, i remember some people complained about crashes with the Megablastmod. Maybe that was caused by that alien numbers being to high...
Fulby\
29 Apr 2004 - 1:56pm
Fulby
Hi CommChe,

A few questions:

What version of Windows are you using?

What is the path UFO:AM is installed to?

Is the RB mod placed in "ALPine\plugins\mods\mod1"?
Please check the exact path, i.e. \mods\ not \mod\

Do other mods work with the mod wrapper?
Download some small mods from UFOaftermath.co.uk if you don't have any.

Renaming to cfg.vfs is not a problem.  The program tries to find a file matching "*cfg*.vfs", then "*mod*.vfs", then returns Nil which is what is causing the error.  Make sure the other mods you try match one of those two patterns.

Fulby
BlackAlmaz\
29 Apr 2004 - 11:43am
BlackAlmaz
looking back in time there was a magablast mod...using rb 3.3 wich increased the alian numbers by 3-4 thats how i once had 35 alians on a damn battle ship (outside)

and the game didnt crash

why dont you have a look at what was done Aralez....or it might not work with UFO:AF 1.3

and i was only able to make the mod wraper work once so i eather use plugins or mods
CommChe\
29 Apr 2004 - 11:32am
CommChe

Fulby, on Mar 21 2004, 12:19 PM, said:

The patch is now available here.

The mod wrapper will now find VFS files matching "*mod*.vfs" and the Plugin Installer has a checkbox to auto-overwrite files when extracting plugins.

Fulby
I downloaded the new alpine (thanks by the way  :(  )

pplying Plugins...
Processing * Mod Wrapper...
Error processing: plugins\1mod.lua
Lua Error: plugins\1mod.lua:18: attempt to concatenate local `cfg' (a nil value)
stack traceback:
code\core.lua:291: in function `alpine_error_handler'
plugins\1mod.lua:18: in main chunk
Processing Tactical Mission Camera Modes...
Processing Blood Patch...
Processing Ammo Manufacturing...
Processing TNT...
Finalising...
Finished processing plugins


still getting this error message whenever I try to use the mod wrapper with RB1.06

what am I doing wrong? Yes, I renamed the rebalance to cfg.vfs. But I tried it first without renaming it and I still got the same message... :(
Aralez\
9 Apr 2004 - 9:17pm
Aralez
As it seems the number of Aliens can't be increased without the game crashing. So a "new difficulty level" -plugin will not be released by me. Sorry!

But i will work on the crew-maximum-plugin.

CU!
Slaughter\
7 Apr 2004 - 3:47pm
Slaughter
Sure Aralez, the more plugins the better :).

@Fulby: Nice! I'll update the ALPine section when I get back from Easter.
Aralez\
6 Apr 2004 - 6:42pm
Aralez
Is anyone interested in an Alpine plugin that limits your crew to seven people? I had this idea when i had  14 or more recruits in my equipment screen and they somehow made me nervous  :)

And did anyone ever try to add a new difficulty level? I thought about something like the "superhuman" level in XCOM....

I could do another Alpine plugin with this, IF it works....
Fulby\
6 Apr 2004 - 4:58pm
Fulby
The ALPine website was having problems and so has moved to a better place, namely  http://www.ufoaftermath.co.uk/alpine/.  My thanks to Pete for the webspace.

ALPine 3.0.2 is now available from the web site as an installer instead of a patch.

Fulby
Slaughter\
21 Mar 2004 - 8:24pm
Slaughter
Sounds good! :) Do tell me when it's ready.
Fulby\
21 Mar 2004 - 3:00pm
Fulby
Of course there's a chance :)

Fulby

 

Add Comment

You must be logged in to reply. Please log in or register an account.